Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 16, 2025 - 20:30 MDT
Scheduled
We will replace aging network hardware. We expect ResNexus to remain mostly available during this time, but there will be brief and intermittent downtime.
Posted Apr 16, 2025 - 20:30 MDT
This scheduled maintenance affected: ResNexus Property Management Software, Direct Connect, ResNexus Website Builder & Hosting, and Phone Support & Home Office.